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Presentation of Chimera 
This introductory course about 3D structure visualization and high quality imaging for publication 
will make use of the free program Chimera. The official website of chimera can be found at the 
following address: http://www.cgl.ucsf.edu/chimera 

Here is a brief description of Chimera and its features taken from the website: 

“ UCSF Chimera is a highly extensible program for interactive visualization 
and analysis of molecular structures and related data, including density 
maps, supramolecular assemblies, sequence alignments, docking results, 
trajectories, and conformational ensembles. High-quality images and 
animations can be generated. Chimera includes complete documentation 
and several tutorials, and can be downloaded free of charge for academic, 
government, non-profit, and personal use. Chimera is developed by the 
Resource for Biocomputing, Visualization, and Informatics, funded by the 
National Institutes of Health (NIGMS P41-GM103311). “ 

 
The program can be downloaded at the following address: 
 http://www.cgl.ucsf.edu/chimera/download.html 
 
When using chimera, one should cite this reference: 
Pettersen, E.F., Goddard, T.D., Huang, C.C., Couch, G.S., Greenblatt, D.M., Meng, E.C., and Ferrin, 
T.E. "UCSF Chimera - A Visualization System for Exploratory Research and Analysis." J. Comput. 
Chem. 25(13):1605-1612 (2004). 
 
 
Generally, scientific journals require EPS or TIFF images, with 300 dots per inch resolution or higher, 
and with RGB colors. You will see how to obtain such images using Chimera.  
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1. Hands on – Loading a structure, moving, zooming, saving 
In this first exercise, we will load a simple small molecule into UCSF chimera to learn the basic 
controls. The small molecule that has been chosen is the Melan-A peptide (MART-127-35), a 
melanoma antigen recognized by T cells. 
Once these basic controls are grasped, it will be easier to handle large proteins, notably 
immunology-related ones.  

 

Loading a structure into Chimera 
 
The following exercise uses the PDB file “Melan-A.pdb”. This file can be downloaded from the 
website https://www.immunology-and-modelling.ch/index.php. 
Create a directory “Immunology” on your machine, for example on the Desktop, and put this PDB 
file in it. For convenience, the Chimera-Immunology directory could be used to store all the files 
that you will get from this website and which will be used in the following exercises. 
 
 
Two methods can be used to load a structure into Chimera. 
 
1) If the structure file is present in the user's computer, choose the menu item “File/Open”. Then 
browse the file system, select “Melan-A.pdb” and click “Open”. 
 

 
 

Under Unix or Mac OSX, the structure (for instance Melan-A.pdb) can also be loaded 
using the following command: 
> chimera Melan-A.pdb & 
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2) The structure might also be fetched from a database, when available. For this, we can choose the 
menu item “File>Fetch by ID…”. Choose the databank and type the name of the entry you would 
like to retrieve. Then click “Fetch”. 
We will use this approach later. 
 

Moving / zooming 
The molecule can be rotated by clicking the left button and dragging the cursor over Chimera's 
window. The translation is obtained similarly, but using the central mouse button. Finally, one can 
zoom in and out using the mouse right button.  
 
  
 
 
 

Changing bond display and color 
 

To show all atoms, including hydrogen atoms, 
select “Actions>Atoms/Bonds>Show”. 
 
In the “Actions>Atoms/Bonds” menu, 
choose successively the “stick”, “ball & 
stick”, “sphere” and “wire” menu items and 
see how the molecule is displayed in each 
case. Finally, choose the “stick” 
representation. 
 

 
 
 

Open the detachable color action menu 
using “Actions>Color>all options…”. You 
can possibly close some other windows to 
save space on the screen. Check the 
“atoms/bonds” button so that the color 
changing will be applied only to atoms and 
bonds. Then, you can select a color from 
the left column that will be used for all 
ligand atoms. Another possibility is to 
color all atoms according to their atom 
types. This is obtained by clicking “by 
element”. 
 

 
 

 

Rotate: press left button and drag 
Translate: press central button and drag 
Zoom: press right button and drag 
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Showing the molecular surface 
 

Click “Actions>Surface>show”. You 
can try modifying the surface 
representation to “mesh” and “dot”. 
Then, go back to the “solid” 
representation.  
 

 
 

It is possible to increase the 
quality of the surface 
representation by changing the 
corresponding attribute. In the 
“Favorites>Model Panel” 
window, select the MSMS 
ligand surface in the left list. 
Then click “attributes” and 
change the “vertex density” 
attribute to 10.0. Press Enter to 
apply the change. 
 

 
 

 
 

This surface gives a good idea of the volume 
occupied by the small molecule. However, it 
also hides the molecule. To correct this, it can 
be made transparent. In the 
“Action>Surface>transparency” menu, select 
70%. 
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Saving image 
Choose an orientation and a zoom that provides a satisfying point of view. Then, select the 
“File>Save Image…” menu item. In the new window, choose an image resolution of 300 dots per 
unit (dpi), and a JPEG quality of 95%. Select “Maintain current aspect ratio”, and enter an “Image 
width” of 15 centimeters. Select the format of the file that will be saved in the “File Type” menu. 
Click “Save As”. Wait while the image is calculated. Scientific journals generally accept TIFF, JPEG 
and EPS files. Finally, choose and “File name” and click “Save”. 
 

 
 

Images are saved as RGB figures. 

Saving the session status 
The Chimera session (the actual representation) can be saved for future use, modifications or 
sharing with a collaborator.  This can be made using the “File>Save Session As...” menu. Select a file 
name and click “Save”. The saved file is actually a python script and will have the “.py” extension.  
A UCSF chimera session file is computer/operating system independent. Therefore, it is possible to 
send it to a collaborator, who will see exactly what you prepared after opening it with in UCSF 
chimera. 

Closing the session. Quitting Chimera 
The session can be closed using the “File>Close Session” menu item. One can quit Chimera with 
“File/Quit”. 

Restoring a previous session 
A previously saved session can be restored using the “File>Restore Session” menu item. Select the 
file (with a .py or .pyc extension) and click “Open”. 
 
IMPORTANT: 
There is no “Undo” action in UCSF Chimera. As a consequence, save a session file often to be able 
to go back to a previous state. Do this each time you need to apply an action that could potentially 
damage your representation, in cases you would apply a wrong action or made a bad selection, 
for instance. 
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2. Manipulate a protein, show/hide atoms and ribbon, select. 

The objective of this exercise is to manipulate proteins, visualize secondary structure elements (helix 
and beta-sheet), show and hide ribbon representation, select specific part of the system and modify 
the corresponding representation. 

 

Open the structure file 
A structure file has been prepared for this exercise. You can access it at the following address: 
https://immunology-and-modelling.ch/chimerax/Secondary-Structure.chimerax 
 
A “chimerax” file is a web data file for Chimera, i.e. it contains instruction for chimera regarding (i) 
where to find the structure file on the internet and (ii) how to display it.  
 
When the computer/OS is configured correctly, clicking on the link of a chimerax file on a web page 
will open automatically UCSF Chimera and load the structure in the chosen representation. 
 
IMPORTANT: On some OS, or with some browsers, UCSF chimera will not be opened automatically 
if you click on a chimerax file. In those cases, download the chimerax file by using the “Save as…” 
option of the browser, and save the file in a directory (here the “Immunology” directory we created 
previously). Then, a double click on the chimerax file will open UCSF chimera and load the structure. 
 
Load/Launch “Secondary-Structure.chimerax” file. 
 

 
 

Coloring the secondary structure elements 

The ribbon can be colored according to the secondary structure element, i.e. strand, helix or loop. 
Open the Model Panel by choosing the “Tools>Depiction>Color Secondary Structure” menu item. 
This will open the “Color Secondary Structure” window. Check the “Helix”, “Strand” and “Coil” 
boxes. For each one, it is possible to modify the default color by clicking on the corresponding 
colored square to open the “Color Editor” window and change the RGB cursors positions. Click on 
the “Apply” button of the “Color Secondary Structure” window to apply the coloring.  
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You can try several color combinations and keep the one you prefer. Finally, you can close the  
“Ribbon”, “Color Secondary Structure” and “Color Editor” windows by clicking the “Close” button, 
or the top right “X” icon. 

 

Changing bonds, atoms and ribbon display 
 

  
 
Display the atoms and bonds by clicking “Actions>Atoms/Bonds>Show”. In the same menu, choose 
successively the “stick”, ball & stick”, “sphere” and “wire” menu item sand see how the atoms and 
bonds are displayed in each case. Finally, choose the “ball & stick” representation. 
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By default, when the ribbon is 
displayed, the backbone atoms are 
hidden. It might be useful to 
display them all the same. To do 
this, you can open the 
“Favorites>Model Panel” menu.  
 

 
 

Then, in the model 
panel, you can select 
the first molecule, i.e. 
the helix. The ID of 
this molecule is 
numbered 0 
(molecule 2 will be 
#1, etc…). On the 
right column of the 
model panel, you can 
click on “Attributes”. 
In the “Attributes” 
window that appears, 
put “ribbon hide 
backbone atoms” to 
“false”. 
  

 
 
It is also possible to hide the ribbon by clicking “Actions>Ribbon>Hide”. 
 
For the following, you can display again the ribbon, and hide the atoms. 
 

Selections using the select menu 
 
In UCSF Chimera, it is possible to select a part of the system, e.g. a residue, an atom or a protein, 
for instance to apply an action to it, while the rest of the system is unchanged. 
 
There are three ways of selecting atoms with Chimera: using the “Select” menu, using the 
“Command Line”, or using the mouse, which are described later. 
 
Using the “Select” menu, you can try selecting different parts of the complex: the water molecules, 
chains A or B of the proteins, the aspartate residues, the strands, etc... 
“Selection Mode” has to be “replace”. Otherwise, choose it with “Select > Selection Mode”. 
The first four menu items allow to select part of the structure according to the “Chain” (protein 
chains), the “Chemistry” (chemical nature of the atoms or functional groups), the “Residue” 
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(residue name or type) and the “Structure” (ligand, water, ions, backbone, side chains, secondary 
structure, etc...). You can try to select different parts of the system. 
As you can see, a green thin line surrounds the selection. 
 

  
 
It is possible to append a selection with a new one. For instance, to select all proteins, you can 
choose the menu items “Select>Selection Mode>append”, then “Select>Chain>A>all” and 
“Select>Chain>B”. 
 
Use the “Select” and the “Actions>Atoms/Bonds” menus to show and hide the water molecules. 
 
Finally, you can clear all selections using “Select>Clear Selection”. 

 

Command line... 
Most of Chimera functionalities can be accessed by typing a given command in the “Command line”, 
which is situated at the bottom of the Chimera window. If the command line is not present, display 
it using  “Favorites>Command Line”. A line preceded by “Command” will appear on the lower part 
of the principal window (see the bottom of the two images above). 

 

Selections using the command line 
The command line can be used to type and execute commands relative to selection and display, for 
instance. To execute a command, one needs to type it in the command line and press Return. The 
union (logical ‘OR’) and intersection (logical ‘AND’) selection keywords are noted “|” and “&”, 
respectively. The negation symbol is “~”.  
A detailed description of the different selection possibilities using the command line are provided 
in the quick reference guide. Here is a limited list showing some possible selections based on our 
particular structure that you could try: 
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Select chain B of molecule #1 and color its 
ribbon in magenta. 
 
How many chains constitute the beta strand? 
 

 
 
 

Selections using the mouse 
 
Using the menus or the command line, display all the atoms in the system, but hide the water 
molecules. 
 

You can select an atom by pressing the 
“Ctrl” key on the keyboard and click on 
the atom. 
 
Once an atom has been selected, pressing 
the “Arrow up” key of the keyboard will 
select the residue to which the atoms 
belong. Pressing a second time the 
“Arrow up” key will select the 
corresponding protein. You can continue 
until you select the whole system. 
Pressing the “Arrow down” key of the 
keyboard will successively narrow down 
the selection till the initially selected 
atom. 
  

“select” : select everything. 
“select :.A” : select chain A of all proteins. 
“select #1:.A”: select chain A of protein ID #1. 
“select :.A,.B” : select chains A and B of the proteins. 
“select :ASP”: select the residue named ASP (aspartate).  
“select :HOH” : select the residue named HOH (water molecules). 
“select :HOH | :ASP” : select both the water molecule and aspartate residues. 
“select :10,25” : select all residues that are numbered 10 or 25 in the PDB.  
“select :25@CA”: select atom Ca of residues 25. 
“select :113.B” : select residue 113 of chain B. 
“select strand” : select strands. 
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You can select several atoms this way: select the first atom by clicking on it while pressing the “Ctrl” 
key on the keyboard. Then press both the “Ctrl” and “Shift” keys on the keyboard and click on the 
second atom. 
You can select as many atoms as you wish. 
 

Label residues 
 

Select atoms Cb of residues 99 by typing 
“select :99@CB” in the command line. 
Choose “Actions>Label>residue>name + 
specifier”. You can try other types of 
labeling. Possibly, you can change the 
label color using the “Color” window, 
checking “residue labels” and choosing a 
color. 
 

 
 
 
IMPORTANT: you can identify a residue by letting the mouse over it during 1 second. 
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3. Showing hydrogen bonds & Clipping protein surface. 

Open the 3D structure of the complex between HLA-A*0201 and the MART-1/Melan-A peptide by 
clicking on the following link (or by downloading it): 
https://www.immunology-and-modelling.ch/chimerax/StartExercise3.chimerax  
 

d 
 
Open the “Model Panel” and identify the ID (i.e. the number of the molecule) corresponding to the 
MHC, the b-microglobulin and the peptide. 
 
Display the peptide in ball and stick, colored according to the atom types. 
 

Calculating and showing hydrogen bonds 
 
Chimera can calculate and display the hydrogen bonds between selected atoms. 
 

  
 
To display the hydrogen bonds between Val9 of the peptide and MHC, follow this procedure 
First, open the “Tools>Surface/Binding Analysis/FindHBonds” menu. 
Then select residue Val9 of the peptide.  
In the “H-bonds parameter” menu, choose “Only find H-Bonds with at least one end selected”, and 
select “If endpoint atom hidden, show endpoint residue”. 
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Click “Apply”. 
You can change the hydrogen bond color and line width from the “H-Bond Parameters” window, 
and click “Apply” to apply them. 
 
What are the possible hydrogen bonds? Which MHC residues are involved? 
 
Similarly, display the hydrogen bonds between peptide Leu2 and MHC.  
Are they involving the backbone or the side chain of the residue?  
Are these hydrogen bonds responsible for the fact that residue 2 is an anchor residue? 
 

Showing residues interacting with given atoms 
 
Using the mouse or the selection menu, select the side chain atoms of residue Leu2 of the peptide. 
Then, type “select sel z<4.5 & #0” in the command line to select all MHC (#0) residues within 4.5 Å 
from the selected atoms, and display them as sticks. In addition, display the surface of these atoms 
using “Actions>Surface>Show”. Increase the vertex density of the surface to 10 using the 
“Attributes” panels. 
 

 
 
What type of interactions are responsible for the fact that residue 2 of the peptide is an anchor 
residue? What MHC residues are involved?  
IMPORTANT: Note the number of these residues, they will be used later! 
 

Clipping protein surface 
 
Clipping protein surface allows analyzing buried pockets. 
 
Using the model panel, close the surface you created above (select it in the list and click “close”). 
Select the entire MHC molecule, and display its surface. Again, increase the vertex density of that 
surface to 10. 
While the MHC molecule is still selected, hide its atoms and ribbons using the corresponding 
“Action” submenus. 
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Open the “Tools>Depiction>Per-Model Clipping” menu.  
Select the model corresponding to the protein surface and choose ”Enable Clipping”. Then check 
the “Adjust clipping with mouse as bellow” option. 
Use the central and right button of the mouse to adjust the clipping plane so as to see correctly the 
MHC pockets occupied Leu2 and Val9. 
To get back the usual control of rotation/translation/zoom, uncheck the “Adjust clipping with 
mouse as bellow” option. 
 

 
 

 
You can remove the capping of the surface, or remove it, using the “Surface capping…” submenu. 
 

 
 

 
Before going to the next section, please, switch off the surface clipping. 
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Using side view and depth cueing 
 
Several options are very useful to create a better 3D effect on images or on the screen. 
 
Open the “Viewing” menu by choosing the “Favorites>Side view” menu item. The “Side View” tab 
of the “Viewing” window should be active. Otherwise, click on the “Side View” tab. You will see a 
reduced view of the structure appearing in the “Viewing” window. The vertical lines show the 
clipping planes that define the region of space displayed on the screen. The square gives the viewer's 
eye position. The red lines show the field of vision.  
Clicking the “View All” button adjusts the scale and clipping plane positions so that the view will 
include everything that is displayed. It is possible to move the position of the viewer's eye and 
clipping planes using the mouse. 
 

If you drag the rear clipping 
plane closer to the protein, you 
will see the effect of the depth 
cueing, which causes regions 
farther from the viewer to be 
shaded. The depth cueing 
parameters can be changed in 
the “Effects” tab of the 
“Viewing” window. 
 

 
 

Changing the Lighting 

It might be useful to change the lighting 
(intensity and direction) to get a better 
view of the system. Select the “Lighting” 
tab in the “Viewing” window. This tab 
displays the light sources and parameters. 
The key light is the dominant brighter 
source of light. The fill light gives a 
secondary source. The solid arrows in the 
right view allow manipulating the lighting 
directions with the mouse. You can try 
different lighting directions to see their 
effect. 
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4. Superposing and comparing 3D structures 
 

Load and clean the structures 
 
The idea of this exercise is to load to 3D structures in UCSF chimera, both corresponding to 
complexes between MHC HLA-A*0201 and Melan-A peptides (AAGIGILTV or ALGIGILTV), and 
explain qualitatively the difference in affinity of the two peptides for the same HLA protein. 
 

Peptide Affinity for HLA-A*0201 PDB ID 
AAGIGILTV 60 µM 2GUO 
ALGIGILTV 1.5 µM 1JHT 

Valmori, D., Fonteneau, J. F., Lizana, C. M., Gervois, N., Liénard, D., Rimoldi, D., et al. (1998). Enhanced generation of specific tumor-reactive CTL in 
vitro by selected Melan-A/MART-1 immunodominant peptide analogues. Journal of Immunology, 160(4), 1750–1758. 

 
Using the “File>Fetch by ID…” menu, load the 
2guo and 1jht PDB files. 
 
Note: If the Protein Databank is not responding, the 
two files can also be obtained from the lecture website 
at https://www.immunology-and-modelling.ch/. 
 

 
 
Select chain D, E and F, and delete them with “Actions>Atoms/Bonds>Delete”. 
Select water molecules and delete them. 
Hide all atoms 
 

3D superposition of the complexes 
 

To compare the two complexes, it is more 
convenient to superpose them in 3D. For this, 
open the “MatchMaker” menu using 
“Tools>Structure Comparison>MatchMaker”. 
In the MatchMaker menu, select 2guo as a 
“Reference structure” and 1jht as a “Structure 
to match”. Check that all options are selected 
as in the image below, then click on “Apply”. 
You should obtain a superposition of the two 
MHC molecules, along with their sequence 
alignment. Since these two MHC are the same, 
you can remove the sequence alignment. 
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Display the peptides and compare their binding modes 
 
Select the peptides (chains C), and display them in ball and stick.  
 

Open the “Tools>Sequence>Match 
-> Align” menu and select chains C in 
the list of chains (all others should 
be unselected).  
Click “Apply”. You should get a 
sequence alignment of the two 
peptides.  
You can use the sequence alignment 
to select pairs of aligned residues 
and compare their binding position.  
  

Do you see huge differences in the overall binding modes? 
 

Select the MHC residues that are known to interact with residue 
2 of the peptide (you have listed them in Exercise 3). Display them 
as sticks. Do this for the two MHC.  
 
Do you see a difference in their position between the two 
structures? 
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For structure 1JHT only, select the 
MHC residues interacting with 
peptide residue 2, and display their 
surface. Set the surface 
transparency to 50%.  
 
Select the side chain of residue 2 of 
both peptides and display them as 
Spheres. 
Use the “Model Panel” to display 
1JHT or 2GUO, while hiding the 
other. 
  

 
Which peptide fills the best this pocket? What types of interactions are exchanged? Could this 
explain the difference in affinity between the two peptides? 
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5. Explaining anchor residues of HLA-B*2705 (Optional). 
 
Here is the sequence logo for HLA-B*2705: 

 
Bassani-Sternberg, […] Gfeller. (2017). PLoS Computational Biology, 13(8), e1005725.  

 
 
What are the most favored residues in the anchor positions 2 and 9? What types of interactions 
could they make with MHC? 
 
 

 
Search for “HLA-B2705” in the PDB.  
Select an experimental structure in which 
the peptide has 9 residues, with an Arg 
residue in positions 2 and 9, and load it 
into UCSF chimera. 
 
Identify the interactions between 
residues Arg2 and Arg9 of the peptide and 
MHC HLA-B*2705. 
 
What types of interactions are present? 
Are they different from those between 
HLA-A*0201 and Melan-A? 
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6. Analyzing interactions in pMHC Class II complexes (Optional). 
 

Load the experimental 
structures 3L6F, 1FYT and 1AQD 
in UCSF Chimera. 
 
Delete all chains except chains 
A, B and C. 
Delete water molecules. 
 
Show chains A and B as ribbons 
(hiding the residues) and chains 
C in ball and stick (hiding the 
ribbon). 
 
Use “Tools>Structure 
Comparison>MatchMaker” to 
superpose all structures on 
3L6F. 
  

 
What is the common HLA protein? 
 
The peptides are composed of how many residues? 
 
What can we say about the position of the backbone of the peptides? 
 

Use the “Tools/Structure 
Comparison/Match->Align” tool to align 
the peptide sequences (chains C, only).  
 
Use the “Headers” menu to remove the 
RMSD from the header, and add 
“Conservation”, “Consensus” and “Charge 
variation”. 
 
 
What is the most conserved position? 
 
 
Is it facing HLA or the solvent? 
 
 
What are the residues defining the 
pocket in which this residue is bound? 
 
 
What types of interactions are taking 
place? 
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7. Analyzing the TCR/pMHC complex, and suggesting possible 
modifications of TCR to enhance its affinity. 
 

Load the 2BNR PDB structure into UCSF chimera 
and produce a molecular representation similar to 
the one you see on the right 
 
Display the atoms of the CDRs for TCRa and TCRb 
in stick or wire representation, colored according 
to the atom types.  
You can keep the ribbon representation for the 
backbone, and use a different color for the ribbon 
for each CDR. 
 
Note: The CDRs are defined in the table below. 
 

Chain CDR Residues 

TCRa 
CDR1 28-32 
CDR2 51-55 
CDR3 94-101 

TCRb 
CDR1 25-29 
CDR2 49-53 
CDR3 94-100 

 
 
What are the CDRs that make most of the 
contacts with the peptide epitope? And with the 
MHC? 
 
  

 
What are the TCR residues that make contact with 
peptide Trp5? What types of interactions are taking 
place? 
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What MHC residues are close to TCRb 
Ala51? 
 
If you wanted to change residue 51 of 
TCRb what mutation would you introduce? 
Why? 
 

 
 
 
 
 
 


